Given a double-precision number,payment, denoting an amount of money, use the NumberFormat class’ getCurrencyInstance method to convert payment into the US, Indian, Chinese, and French currency formats. Then print the formatted values as follows:
US: formattedPayment
India: formattedPayment
China: formattedPayment
France: formattedPayment
where formatedPayment is payment formatted according to the appropriate Locale’s currency.
Note: India does not have a built-in Locale, so you must construct one where the language is en (i.e., English).
Input Format
A single double-precision number denoting payment .
Output Format
On the first line, print US: u where u is payment formatted for US currency.
On the second line, print India: i where i is payment formatted for Indian currency.
On the third line, print China: c where c is payment formatted for Chinese currency.
On the fourth line, print France: f, where f is payment formatted for French currency.
Sample Input
12324.134
Sample Output
US: $12,324.13
India: Rs.12,324.13
China: ï¿¥12,324.13
France: 12 324,13 €
SOLUTION:
import java.io.*;
import java.util.*;
import java.text.*;
import java.math.*;
import java.util.regex.*;
public class Solution {
static String converter(Locale locale, double payment) {
NumberFormat nFormat = NumberFormat.getCurrencyInstance(locale);
return nFormat.format(payment);
}
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
double payment = scanner.nextDouble();
scanner.close();
System.out.println("US: " + converter(Locale.US, payment));
System.out.println("India: " + converter(new Locale("en", "IN"), payment));
System.out.println("China: " + converter(Locale.CHINA, payment));
System.out.println("France: " + converter(Locale.FRANCE, payment));
}
}
FOLLOW FOR MORE QUESTIONS AND SOLUTIONS | DIGIT WOOD
Leave a Reply