Java Primality Test in Java : Hacker Rank Solution : Digit Wood

Java
,

A prime number is a natural number greater than  whose only positive divisors are  and itself. For example, the first six prime numbers are 2,3,5,7,11, and 13.

Given a large integer,n , use the Java BigInteger class’ isProbablePrime method to determine and print whether it’s prime or not prime.

Input Format

A single line containing an integer, n (the number to be checked).

Constraints

  1. n contains at most  digits.

Output Format

If n is a prime number, print prime; otherwise, print not prime.

Sample Input

Sample Output

Explanation

The only positive divisors of 13 are 1 and 13 , so we print prime.

SOLUTION :

import java.io.*;
import java.math.BigInteger;

public class Solution {
    public static void main(String[] args) {
        try (BufferedReader bufferedReader = new BufferedReader(new InputStreamReader(System.in))) {
            BigInteger number = new BigInteger(bufferedReader.readLine());
            if (number.isProbablePrime(1)) {
                System.out.println("prime");
            } else {
                System.out.println("not prime");
            }
        } catch (IOException e) {
            System.out.println("Could not validate input");
        }
    }
}

FOLLOW FOR MORE QUESTIONS AND SOLUTIONS | DIGIT WOOD

Leave a Reply

Your email address will not be published. Required fields are marked *