We use the integers a,b, and n to create the following series:
You are given q queries in the form of a,b, and n . For each query, print the series corresponding to the given a,b, and n values as a single line of space-separated integers.
Constraints
0<=q<=500
0<=a,b<=50
0<=n<=15
Output Format
For each query, print the corresponding series on a new line. Each series must be printed in order as a single line of n space-separated integers.
Sample Input
2
0 2 10
5 3 5
Sample Output
2 6 14 30 62 126 254 510 1022 2046
8 14 26 50 98
SOLUTION:
import java.util.*;
import java.io.*;
class Solution {
public static void main(String[] argh) {
Scanner in = new Scanner(System.in);
int t = in.nextInt();
for (int i = 0; i < t; i++) {
int a = in.nextInt();
int b = in.nextInt();
int n = in.nextInt();
int m = a;
for (int j = 0; j < n; j++) {
m += Math.pow(2, j) * b;
System.out.print(m + " ");
}
System.out.print("\n");
}
in.close();
}
}
FOLLOW FOR MORE QUESTIONS AND SOLUTIONS |Â DIGIT WOOD
Leave a Reply